Linux更新系统漏洞或补丁

使用命令

# yum upgrade

# apt-get

命令,即可自动更新系统漏洞或补丁。

 

-y 表示后面有问答直接回复y,可以在测试环境中验证好了,然后再跳过问答。

# yum upgrade -y

 

CenterOS的update和Ubuntu的update不一样!

yum update:升级所有包同时也升级软件和系统内核

yum upgrade:只升级所有包,不升级软件和系统内核

测试样例:

一、升级前

系统版本: centos5.5
内核版本: 2.6.18-194.el5

二、yum upgrade 升级后,只升级所有包,不升级软件和系统内核

系统版本: centos5.7
内核版本: 2.6.18-194.el5

三、yum update 升级后,升级所有包同时也升级软件和系统内核

系统版本: centos5.7
内核版本: 2.6.18-238.el5

 

参考文档:《CentOS下的yum upgrade和yum update区别,没事别乱用,和Ubuntu的update不一样!》

点赞

暂无评论

发表评论

您的电子邮件地址不会被公开,必填项已用*标注。

相关推荐

Linux使用 history 查看命令执行时间方案

在linux下,有时我们需要知道有些命令执行后,运行大概花费了多少时间,这个时候我们就需要用到以下命令: # export HISTTIMEFORMAT="%Y-%m-%d %H:%M:%S " # history 所以,可以在某些命令执行完毕之后,打一些不痛不痒的命令,例如:# ls ,这样就可以在使用历 ...

vi/vim 不正常退出产生的swp文件如何处理

在使用Linux的操作系统中,当我们在非正常关闭vi/vim编辑器时会生成一个.swp文件,可能就会出现类似以下报错,而且每次使用都会有该提示: “.bash_profile.swp” already exists! [O]pen Read-Only, (E)dit anyway, (R)ecover, (Q)uit: 产生以上报错的原因大致分 ...

linux修改文件权限遭遇Operation not permitted

当想给文件夹赋予777权限,然后你看到以下提示: [root@server wwwroot]# chmod -R 777 wenjian chmod: changing permissions of ‘wenjian/.user.ini’: Operation not permitted 心情(/ □ \)…… 是 user.ini 这个文件不允许修改导致的报错。 解决起来也也很容易 ...

Gogs安装配置手册

一、适用范围及环境: 阿里云服务器操作系统:CentOS 7.4 ; 二、安装步骤: 1. 使用yum安装Git: # sudo yum install git 2. 添加git用户: # sudo useradd git 3. 查看CentOS内核版本,确定架构(x64、x86还是arm) # uname -a 4. 下载与其对应的二进制安装包 ...

微信扫一扫,分享到朋友圈

Linux更新系统漏洞或补丁